Which type of device recommended to use Finalcad One ?

Have you started your FINALCAD adventure and want a better device ?

We have found a selection to choose from according to your OS use type.

 

iOS(Apple):


iPhone*

  • iPhone 12 Pro
  • iPhone 12
  • iPhone SE (2e generation)
  • iPhone 11
  • iPhoneX🅁

iPad*

  • iPad Pro (12,9 pouces) (5e generation)
  • iPad Pro (11 pouces) (3e generation)
  • iPad Air (4e generation)
  • iPad (8e generation)
  • iPad mini (5e generation)


Android** (Google) :

Tablettes* :

  • Samsung Galaxy Tab S7
  • Samsung Galaxy Tab S5e
  • Samsung Galaxy Tab S6 Lite
  • Lenovo Tab P11

Smartphones* :

  • Samsung Galaxy S20 Ultra
  • OnePlus 8 Pro
  • OnePlus Nord 2 5G
  • OnePlus Nord CE 5G
  • Xiaomi Mi 10
  • Xiaomi Redmi Note 10 5G

 

How can I protect my device ?

We know that life on a construction site is unpredictable. If a device fall can soon happen. To best protect it, we advise you to equip your team with an Otterbox “Defender Series”  protective case :Internet Site, and also atravel bag, which is very practical for daily use.   


* 32 Go for average use, 128 more for the freedom of long term usage

 

Minimum version of your system

Before you install or update FINALCAD or FINALCAD LIVE, make sure you have the minimum required version of your operating system:

  1. To install the latest version of Finalcad One, you must have at least:
    • Android version 5.0.0
    • iOS version 13.0
  2. To install the latest version of Finalcad Classic, you must have at least:
    • Android version 5.0.0
    • iOS version 11.0
  3. To install the latest version of Finalcad Live, you must have at least:
    • Android version 5.0.0
    • iOS version 11.0

For any question regarding your devices, please refer to apple/android support page. 

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.

Articles in this section